Issues downloading some documents in Console

Incident Report for Check

Resolved

Document downloads in Console are operational following the resolution of increased error rates and latencies from the AWS us-east-1 region. The latest resolution time was 5:16am ET.
Posted Oct 29, 2025 - 13:43 UTC

Identified

Attempts to download a subset of documents in Console are returning errors. The root cause has been identified and will be resolved upon working through a deployment issue with a vendor.
Posted Oct 28, 2025 - 22:51 UTC
This incident affected: Console.