Some Employee Payments Landing at 1pm ET

Incident Report for Check

Resolved

Incident is now resolved. All impacted employees have been paid. Root cause has been identified.
Posted Feb 28, 2025 - 20:26 UTC

Update

This incident only impacts employee payments made using Instant Payments. The Check team will follow up with a list of all impacted companies and workers.
Posted Feb 28, 2025 - 15:15 UTC

Monitoring

We are aware of several employee payment failures the morning of February 28th. You may experience employees reporting that payments have not yet landed in their accounts. Everyone will be paid today. Employee payments are being processed via Same Day ACH and these will land by 1pm ET.
Posted Feb 28, 2025 - 15:10 UTC
This incident affected: Payments.