Instant payment status reporting delayed

Incident Report for Check

Resolved

The issue is now resolved and statuses are updated
Posted Jan 07, 2026 - 16:53 UTC

Investigating

We're investigating an issue where Instant Payment transactions from this morning are still displaying as Pending. We've confirmed that this purely a reporting issue and all payments have been sent
Posted Jan 07, 2026 - 16:18 UTC
This incident affected: Payments.