Spikes in Check API Latency and Errors

Incident Report for Check

Resolved

This issue has been resolved. This morning Check experienced a database overload from increased webhook traffic that spiked for a a period of time on the morning of 4/24, and surfaced as high latency and error count. The team identified the issue, resolved the immediate database load concerns and restored functionality. The Check engineering team will be following up promptly with a resolution to prevent recurrence.
Posted Apr 24, 2026 - 21:10 UTC

Update

System is recovering. We are still investigating this issue to understand root cause and therefore prevent recurrence, as well as assessing potential impact.
Posted Apr 24, 2026 - 13:36 UTC

Investigating

We identified spikes in API latency and errors. Investigation in progress.
Posted Apr 24, 2026 - 13:33 UTC
This incident affected: API and Console.