Elevated API latency

Incident Report for Check

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 15:23 UTC

Monitoring

Latency has stabilized. We'll continue to monitor
Posted Jan 05, 2026 - 13:48 UTC

Identified

Since 11pm ET last night (Jan 4th) the API has had elevated latency across all resources. We've identified the issue and are implementing a fix.
Posted Jan 05, 2026 - 13:38 UTC
This incident affected: API, Console, and Onboard.