MO state tax not calculating
Incident Report for Check
Resolved
We've identified the impacted payrolls and will be reaching out today with next steps to get these resolved. If you do not receive any communication from Check today, you were not impacted by this incident.

Please reach out to us if you have any questions or need additional information on this incident.
Posted Sep 12, 2022 - 17:37 UTC
Identified
As we've continued our investigation, we have identified the root cause of the issue and have additional details to share. To clarify the issue, any payroll previews and/or approvals generated after 11:26 AM EDT on September 9th did not include Missouri State Tax withholding for employees earning wages in a Missouri workplace.

We are also in the process of rolling out a fix for this issue and will provide an update when that has deployed.
Posted Sep 12, 2022 - 17:25 UTC
Investigating
Any payroll with an employee working in Missouri has not been calculating Missouri state tax correctly since Sept 8th 2022 7PM EST.
Posted Sep 12, 2022 - 17:12 UTC
This incident affected: API.