[RESOLVED] Payroll endpoints degraded for one hour starting 12:15am ET

Incident Report for Check

Resolved

From about 12:15am to 1:15am ET on Feb 16, users experienced elevated latencies and HTTP 5xx responses on payroll endpoints from unexpected contention caused by a routine database migration. Service indicators returned to normal around 1:15am. We will be analyzing the event to prevent recurrences.
Posted Jan 16, 2026 - 05:00 UTC