Increased Payroll Preview 500s
Incident Report for Check
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 19:22 UTC
Monitoring
A fix has been deployed and we are monitoring for any issues.
Posted Oct 04, 2022 - 19:09 UTC
Investigating
We are currently investigating the issue with increased 500s in payroll preview.
Posted Oct 04, 2022 - 18:58 UTC
This incident affected: API.