Increased Errors on Payroll Endpoint

Incident Report for Check

Resolved

The scope of impact was limited to deleting payrolls. A fix is live in production and we are seeing complete recovery.
Posted Jun 06, 2025 - 14:12 UTC

Identified

We have identified an issue causing elevated rates of 500 errors on the payroll endpoint. A fix for this issue is currently being deployed.
Posted Jun 06, 2025 - 13:22 UTC
This incident affected: API.