Historical Payroll Data Upload Failures

Incident Report for Check

Resolved

This incident has been resolved.
Posted Oct 24, 2022 - 20:45 UTC

Identified

We are aware of an issue that is preventing uploading historical payroll data in Console. The issue has been identified and we are working on a fix.
Posted Oct 24, 2022 - 20:08 UTC
This incident affected: Console.