500s on payroll preview

Incident Report for Check

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 19:00 UTC

Monitoring

A fix has been deployed, and we are monitoring the results.
Posted Jun 05, 2025 - 17:55 UTC

Identified

We have identified an issue causing elevated rates of 500 errors on payroll preview. A fix for this issue is currently being deployed.
Posted Jun 05, 2025 - 17:14 UTC
This incident affected: API.